Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Falsche Auswertung Key beim anklemmen 5m LCD Kategorie: Verschiedenes (von MartinSt. - 2.10.2012 0:30)
Als Antwort auf Falsche Auswertung Key beim anklemmen 5m LCD von Stephan - 14.08.2012 13:21
Ich nutze:
C-Control Pro Mega128
> Hallo zusammen,
>
> ich habe meine Steuerung im Keller,
> das LCD Display ├╝ber ein Netzwerkkabel im Wohnzimmer (5 Meter )
>
> Im Testdurchlauf ist ein LCD direkt am Board angeschlossen,
> Progamm l├Ąuft, die Auswertung der Folientastatur ist IO.
> Alle Tasten 1,2,3,..# machen was sie sollen.
>
> Klemme ich nun das
> LCD-Display im Keller ab und schlie├če
> das im Wohnzimmer an, zeigt mir das Display alles an wie es
> Programiert wurde.
>
> nun das eigentliche Problem:
> Die Auswertung der Tastatur zeigt mir jetzt schon ein Wert an
> ohne das eine Taste gedr├╝ckt wird.( immer 32768 // 35 ).
> Die 35 (#) wird nat├╝rlich im Programm verarbeitet.
> Es wurde nur das Kabel f├╝r Das Display um gesteckt!!
>
> An der Tastatur liegt es nicht.
>
> Tausche ich die beiden , alles wieder IO,
> ich habe das im Wohnzimmer befindliche LCD-Display an der Wand
> und kann es auch ├╝ber die verbaute SUB-D Verbindung von der Wand abnehmen,
> so w├Ąre nur das Kabel an den Board angeschlo├čen, trotzdem bekomme
> ich eine falsche Tastaturauswertung wieder die 35.
>
> Kabel durchgemessen alles IO.
>
> K├Ânnt Ihr mir helfen
>

Hallo Stephan

Ist das Kabel der Tastatur abgeschirmt?
So wie ich Deine Beschreibung verstehe, wertest Du die Tastatur analog ├╝ber
Widerst├Ąnde aus, richtig?
Das Kabel der Tastatur w├Ąre demnach auch 5m lang, oder?

Gruss
Martin


    Antwort schreiben


Antworten: