Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Variable PRO_BOT128_INIT nicht definiert Kategorie: Programmierung Basic (von Marcel - 12.10.2009 21:10)


So sieht das Programm aus, den Code habe ich aus einer Demo kopiert, da sich diese nicht kompilieren
lie├č (weil Schreibgesch├╝tzt *?*).

________________________________

Sub main()

    PRO_BOT128_INIT()   'PRO-BOT128 System Init

    AbsDelay(1000)      'Wait 1Sec.
    BLL_ON()            'Back LED left "ON"
    BLR_ON()            'Back LED right "ON"
    ENC_LED_ON()        'Encoder IR-LEDs "ON"
    DRIVE_ON()          'Drive "ON"
    BEEP(350,500)       'Beep

    'Drive Forward 50cm, Turn 180┬░, Drive Forward 50cm, Turn 180┬░
    GO_TURN(50,0,180)
    GO_TURN(0,180,160)
    GO_TURN(50,0,180)
    GO_TURN(0,180,160)

    DRIVE_OFF()         'Drive "OFF"
    ENC_LED_OFF()       'Encoder LEDs "OFF"
    BEEP(250,400)       'Beep
    BEEP(350,250)
    BEEP(250,400)

End Sub

____________________________________

Folgende (Fehler)meldungen erscheinen:

├ťbersetze Projekt Odometer
C-Control Pro Compiler (C) 2009  Conrad Electronic
Durchlaufe Pass 1
Durchlaufe Pass 2
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(4,5): Semantik Fehler - Variable PRO_BOT128_
INIT nicht definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(4,21): Syntax Fehler - unerwartetes Symbol:
')'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(4,25): Syntax Fehler - erwartete ')'  ,
gefunden '
'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(7,5): Semantik Fehler - Variable BLL_ON
nicht definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(7,12): Syntax Fehler - unerwartetes Symbol:
')'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(7,25): Syntax Fehler - erwartete ')'  ,
gefunden '
'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(8,12): Syntax Fehler - unerwartetes Symbol:
 ')'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(9,5): Semantik Fehler - Variable ENC_LED_ON
 nicht definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(9,16): Syntax Fehler - unerwartetes Symbol:
 ')'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(9,25): Syntax Fehler - erwartete ')'  ,
gefunden '
'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(10,14): Syntax Fehler - unerwartetes Symbol:
 ')'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(11,5): Semantik Fehler - Variable BEEP nicht
 definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(14,5): Semantik Fehler - Variable GO_TURN
nicht definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(15,5): Semantik Fehler - Variable GO_TURN
nicht definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(16,5): Semantik Fehler - Variable GO_TURN
 nicht definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(17,5): Semantik Fehler - Variable GO_TURN
nicht definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(19,5): Semantik Fehler - Variable DRIVE_OFF
nicht definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(19,15): Syntax Fehler - unerwartetes Symbol:
 ')'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(19,25): Syntax Fehler - erwartete ')'  ,
gefunden '
'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(20,17): Syntax Fehler - unerwartetes Symbol:
 ')'
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(21,5): Semantik Fehler - Variable BEEP nicht
 definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(22,5): Semantik Fehler - Variable BEEP nicht
 definiert
E:C-Control-ProMeine ProjekteOdometerOdometer.cbas(23,5): Semantik Fehler - Variable BEEP nicht
 definiert
23 Fehler - Kompilation abgebrochen.
Schreibe Symboldaten - 7793 bytes..


Ich bin ein totaler Programmier-Neuling, habe mir deshalb auch noch das Buch "Pro-Bot128 selbst
bauen und erfolgreich einsetzen" besorgt, aber auch damit habe ich so meine Probleme...
Zum oben dargestellten Problem: Ich dachte eigentlich, dass PRO_BOT128_INIT() ein Befehl w├Ąre, mit
dem man die Hardware initialisiert und der zu Beginn eines jeden Programmes durchgef├╝hrt werden
sollte.
Also wie definiere ich die Variablen (z.B. PRO_BOT128_INIT)?


Vielen Dank f├╝r die Hilfe!

Sch├Ânen Gru├č
Marcel


    Antwort schreiben


Antworten:

Re: Variable PRO_BOT128_INIT nicht definiert (von Balmer - 10.11.2016 10:57)
Re: Variable PRO_BOT128_INIT nicht definiert (von PeterS - 7.11.2009 16:51)
Re: Variable PRO_BOT128_INIT nicht definiert (von Bluegrafit - 7.11.2009 16:02)
    Re: Variable PRO_BOT128_INIT nicht definiert (von PeterS - 7.11.2009 16:45)