Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Problem mit der 2. Seriellen Schnittstelle Kategorie: Programmierung C (von wellental - 27.03.2011 22:20)
Als Antwort auf Re: Problem mit der 2. Seriellen Schnittstelle von Franz-Peter - 27.03.2011 22:14
Ich nutze:
C-Control Pro Mega128
Stimmt! Dann werd ich mir wohl selber was zusammenbraten.
Danke f├╝r die Tips!
Gru├č,

Max

> Hallo Max,
> Es gibt von Conrad einen Programmieradapter f├╝r die C-Control-I ( 198834-62 ) der eigentlich nur
> ein solcher Pegelwandler ist. Er enth├Ąlt aber auch noch eine kleine Spannungsstabilisierung und
> kostet mehr als das ganze Project-Board.
> Wenn Du den Schaltplan vom Projectboard anschaust, sieht Du aber, dass der Pegelwandler kein
> Hexenwerk ist. Er besteht aus einem IC (MAX202) und 5 Kondensatoren. Das l├Ąsst sich
> problemlos auf dem Lochrasterbereich realisieren. Das IC gibt's auch beim Conrad.
> Gru├č
> Franz-Peter
>
> > Tataaa! Danke! Das erkl├Ąrt einiges. Gibt's da evtl. ein fertiges Modul, das ich nutzen kann?
> > Gru├č,
> >
> > Max
> >
> >
> > > Hallo Max,
> > > die Pins D2 und D3 sind nicht direkt vegleichbar mit dem 9-poligen Anschlu├č der 1. RS232.
> > > Bei dem 9-poligen Stecker liegt zwischen Prozessor und 9-pol. Anschlu├č ein Pegelwandler, um
> > > die 5V Signale auf RS232 Level zu bringen. Hast Du bei der Verwendung der 2. Schnittstelle auch
> > > so einen Pegelwandler eingesetzt? Wenn Du die 5V-Pegel direkt an das PDA/PC gibst, kann es zu
> > > Datenschrott kommen, da die Empf├Ąnger micht unbedingt mit reinen 5V Pegeln klar kommen.
> > > Gru├č
> > > Franz-Peter
> > >
> > > > Servus!
> > > >
> > > > Ich benutze den C-Control Pro Mega128 in Verbindung mit dem C-Control Pro 128 Projectboard,
> > > > das es bei Conrad hier zu kaufen gibt: http://tinyurl.com/63eepyt
> > > >
> > > > In meiner Anwendung soll das Board ├╝ber RS232 mit einem PDA kommunizieren.
> > > > Das ist alles auch kein grosses Problem, nur funktioniert bei mir leider die 2. Serielle Schnittstelle
> > > > auf dem Board offensichtlich nicht so, wie sie soll. Diese ist ja ├╝ber die Pins D2 und D3 auf
> > > > dem Board verf├╝gbar, jedoch kommt da bei mir leider nur Schrott am PDA an.
> > > >
> > > > An der Software auf dem PDA liegt's nicht, da ich am Rechner das gleiche Symptom habe und
> > > > ausserdem das ganze einwandfrei funktioniert, sobald ich die 1. Serielle Schnittstelle verwende,
> > > > die auf dem Board ├╝ber den 9 poligen Stecker nach aussen gef├╝hrt ist. Diese auf Dauer zu verwenden,
> > > > ist f├╝r mich keine Option, da diese auch zum Programmieren und vor allem zum Debuggen verwendet wird.
> > > >
> > > > Die Signalmasse f├╝r den RS232-Anschluss zum Rechner hab ich mir ├╝brigens vom UNIT-BUS geklaut.
> > > > Das sollte aber wohl nicht das Problem sein, oder?
> > > >
> > > > Danke schonmal,
> > > >
> > > > Max


    Antwort schreiben


Antworten: