Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Töne völlig schräg Kategorie: Pro-Bot128 (von PepeV - 20.08.2011 17:11)
Als Antwort auf Töne völlig schräg von Ralf - 26.07.2011 22:08
Ich nutze:
C-Control Pro Mega128
Hi Ralf,

The AL-60P01 speaker on the Pro-Bot is not a very good one. In the specifications sheet you can
read that the frequency response is far from flat and that the speaker has resonance frequencies at
2048 and 4096 Hz. This causes a lot of distortion. Because the signal send to the speaker is a
square wave, it contains lots of higher harmonics. Combined with the awkward frequency response
of the speaker, you will often hear only these higher harmonics. So what you heard is to be expected.

I can't say why this 'wildes Rauschen' remains after your program. May be because you have no
'neat' ending of your program which causes the bot in an ill defined state. I think I read somewhere
that it is better to keep the program in an endless loop.

Regards,
Pepe

> Hallo liebes Forum,
>
> ich habe den Pro-Bot 128 und nutze die Beep-Funktion zusammen mit den Tone-Konstanten.
>
> Ich habe folgenden Code geschrieben:
>
>     BEEP(Tone_C1, 500)
>     BEEP(Tone_D1, 500)
>     BEEP(Tone_E1, 500)
>     BEEP(Tone_F1, 500)
>     BEEP(Tone_G1, 500)
>     BEEP(Tone_A1, 500)
>     BEEP(Tone_H1, 500)
>
> Das Ergebnis ist keine Tonleiter, sondern eine Katastrophe. Total schrÀg.
> Die Töne werden außerdem nicht immer höher, sondern mittendrin unhörbar hoch und dann wieder tief.
> Und wenn die Tonfolge abgespielt ist, dann bleibt hinterher ein wildes Rauschen.
>
> Habe ich falsch programmiert oder verdrahtet oder ist das normal ?
>
> Ich bitte um Eure Hilfe.
>
> Gruß,
> Ralf


    Antwort schreiben


Antworten: