Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Hohe EMV Empfindlichkeit des LCD Displays Kategorie: CC-Pro Unit & Appl.Board (von H.Heuer - 25.12.2010 20:37)
Als Antwort auf Hohe EMV Empfindlichkeit des LCD Displays von Jo - 22.12.2010 21:11
Ich nutze:
CC-Pro 128 Application Board, Pro-Bot128
> Hi zusammen,
> das Display zeigt regelm├Ą├čig Schrott an, wenn Relais geschalten haben (sind galvanisch Getrennt und
> h├Ąngen auch an einem eigenen Trafo)
> ├ťber ein Reinit (LCD_Init() )bekommt man zwar SW Technisch die Anzeige korrekt, ich w├╝rde jedoch
> gerne wissen,, ob andere auch diese Erfahrung gemacht haben und welche EMV Gegenma├čnahmen
> (Abschirmungen, Kondensatoren, ...) geholfen haben und welche nichts n├╝tzen.
>
> Danke und Viele Gr├╝├če
>
> Jo

Hallo Jo,
ich hatte ├Ąhnliche Probleme, beim Schalten der Netzspannung mit einem Relais
zeigte mein Display (20x4) immer Schrott an.

Ich habe getestet:
- Block Kondensatoren
- Grosse Elkos in der Versorgungsspannung
- Netzfilter in der Zuleitung
- Abschirmung der Relais (Faraydischer K├Ąfig)

Nichts hat wirklich geholfen!

Das einzige was einigerma├čen geholfen hat, war das Austauschen
der mechanischen Relais gegen ein Solid State Relais mit Nullspannungsdetektor.
Allerdings habe ich gelegentlich immer noch Schrott im Display.
Fr├╝her: Jede Stunde
Jetzt: Alle 2 Tage.
Die gleichen Probleme hatte ich auch schon mit der C-Control 1.

Da mich das ziemlich nervt, rufe ich in der Software
st├╝ndlich 1x "LCD_Init" auf.

Ich hatte schon mal die Idee den Displayinhalt auszulesen um dann
"LCD_Init" nur dann aufzurufen wenn der Display Inhalt Schrott war.
Das schien mir aber zu aufw├Ąndig zu sein und hab's verworfen.

Falls du eine L├Âsung findest w├Ąre es super wenn du diese hier postest!

Gru├č,
Hartmut


    Antwort schreiben


Antworten:

Re: Hohe EMV Empfindlichkeit des LCD Displays (von Jo - 25.12.2010 22:33)