Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Display-Fehler Kategorie: Sonstige Hardware (von Francesco - 27.02.2011 10:12)
Als Antwort auf Re: Display-Fehler von Honkomat - 26.02.2011 8:28
Ich nutze:
C-Control Pro Mega32, C-Control Pro Mega128, CC-Pro 32 Application Board, CC-Pro 128 Application Board, Pro-Bot128
> > > Hallo J├Ârg,
> > >
> > > ein Oszilloskop kann ich leider nicht auftreiben. An der Strombegrenzung
> > > kann es aber auch nicht liegen, da die St├Ârungen auch da sind, wenn ich
> > > das Display nicht von der Station aus versorge.
> > >
> > > Ich komme so nicht weiter. Ich denke mal, ich werde nochmal ein anderes
> > > Display versuchen oder gleich auf ein anderes MC-System umsteigen. Denn
> > > die von Conrad empfohlenen Displays sind mit rund 30,- EUR schon etwas
> > > teuer, um nur mal so eben eins zum probieren zu kaufen.
> > >
> > > Falls noch jemand eine Idee hat...
> > >
> > > Viele Gr├╝├če
> > > Christian
> >
> > Einen ├Ąhnlichen Effekt habe ich auch schon bei mir gehabt.
> > Je nachdem wie das Displaykabel gef├╝hrt war, kam es zu Aussetzern.
> >
> > Die L├Âsung war allerdings ganz einfach. Ich habe im Programm
> > vor jedem Textwechsel im Display den Befehl LCD_TEST_BUSY benutzt.
> > Danach war Ruhe im Karton. Ich denke geringste St├Ârungen waren in der Lage das Timing
> > oder die Signale der LCD-Ansteuerung soweit aus dem Lot zu bringen, dass es abgest├╝rzt ist.
> >
> > Ciao, Francesco
>
> Hallo Francesco,
>
> ich habe versucht, etwas ├╝ber den Befehl in Erfahrung zu bringen,
> aber die Informationen im Internet sind sehr d├╝rftig. Was genau
> bewirkt der Befehl? Denn ich habe mal versucht, ihn mit einzubinden,
> doch das hat nur bewirkt, dass das Display extrem langsam wurde. Die
> Station scheint auf irgend etwas zu warten... wahrscheinlich ja, dass
> das Display nicht mehr besch├Ąftigt ist. Aber egal wo ich es eingesetzt
> habe, es hat nur bewirkt, dass das Programm eine mehrere Sekunden
> dauernde Pause macht.
>
> Viele Gr├╝├če
> Christian

Hallo Christian,

Mir war gar nicht klar, dass die Mini Station keinen extra Port f├╝r
die LCD Anzeige hat. Deshalb funktioniert vermutlich der Standard
Befehl (Busy-Pr├╝fung) nicht.
Ich habe jetzt mal in den Schaltplan geschaut. Die Ausg├Ąnge sind aus
EMV-Gr├╝nden stark gefiltert und scheinen eher f├╝r langsame Signale
ausgelegt zu sein. Deshalb scheint es eher Gl├╝ck zu sein, wenn beim
Display etwas sinnvolles ankommt.
In diesem Fall kann wirklich nur eine Betrachtung der Signale weiterhelfen
und eine Anpassung der Bauteile auf dem Board.

Wenn du im L├Âten fit bist, kannst du auch versuchen die Displaysignale
direkt vom Controller abzunehmen statt an der Ausgangsklemme.
Dann umgehst du die Filterung und bekommst definiertere Signale.

Ciao, Francesco



    Antwort schreiben


Antworten:

Re: Display-Fehler (von Joerg - 27.02.2011 12:51)