Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Port auf High setzen Kategorie: CC-Pro Unit & Appl.Board (von juergen - 8.01.2014 21:44)
Als Antwort auf Re: Port auf High setzen von Max - 8.01.2014 20:46

> > > > > > Hallo, ich beschäftige mich neu mit dem C-Control AVR32Bit Bord.|
> > > > > > Alles soweit verstanden. Nur bekomme ich es nicht hin, einen Port als Ausgang auf High zu setzen.|
> > > > > > Als Eingang, ja.|
> > > > > > Mein Code:|
> > > > > >
> > > > > > #define taster P18|
> > > > > > #define ausgang P19|
> > > > > > Sub Lichtschalter_abfragen()|
> > > > > >         If (Port_ReadBit(taster)=0) Then|
> > > > > >             Port_WriteBit(PORT_LED1, PORT_ON)<
> > > > > >             Port_WriteBit(ausgang, PORT_ON)|
> > > > > >         Else|
> > > > > >             Port_WriteBit(PORT_LED1, PORT_OFF)|
> > > > > >             Port_WriteBit(ausgang, PORT_OFF)|
> > > > > >         End If|
> > > > > > End Sub|
> > > > > > Sub main()|
> > > > > >     Port_Attribute(taster,PORT_ATTR_INPUT)|
> > > > > >     Port_Attribute(taster,PORT_ATTR_PULL_UP)|
> > > > > >     Port_Attribute(ausgang,PORT_ATTR_OUTPUT)|
> > > > > >     Port_Attribute(ausgang,PORT_ATTR_INIT_LOW)|
> > > > > >     Port_Attribute(ausgang,PORT_OFF)|
> > > > > >     Port_Attribute(PORT_LED1, PORT_OUT|
> > > > > >     Port_WriteBit(PORT_LED1, PORT_OFF)|
> > > > > >
> > > > > >     Do While True|
> > > > > >         Lichtschalter_abfragen()|
> > > > > >     End While|
> > > > > >
> > > > > > End Sub|
> > > > > >
> > > > > > Hab schon alles probiert, am Ausgang liegen keine rund 3V an.|
> > > > > > Hat jemand einen Tipp für mich?|
> > > > > > Port sind für nichts anderes vorgesehen.|
> > > > > >
> > > > > > Gruß Jürgen W.|
> > > > >
> > > > > Hallo,
> > > > > 3V ist High.
> > > > > Die AVR arbeitet mit 3,3V
> > > > >
> > > > > Gruß
> > > > > Max
> > > > Danke für die Antwort, aber es liegt gar nichts an 0,0...V
> > > > Ich wäre ja mit 3V hoch zufrieden...
> > > >
> > > > Gruß Jürtgen
> > >
> > > Schau dir mal die Demos unter "Port" an.
> > > LG Max
> > das habe ich getan ,siehe mein code. ich kann nicht sehen, was ich falsch mache.
> > gruss jürgen
>
> Das oderiren ist falsch!
> Du schreibst
>
> Port_Attribute(taster,PORT_ATTR_INPUT)|
> Port_Attribute(taster,PORT_ATTR_PULL_UP)|
>
> und so sollte es aussehen.
>
> Gruß Max
> Port_Attribute(taster,PORT_ATTR_INPUT|PORT_ATTR_PULL_UP)


    Antwort schreiben


Antworten:

Re: Port auf High setzen (von juergen - 8.01.2014 21:50)
    Re: Port auf High setzen (von Juergen W - 9.01.2014 7:55)