Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Dauerpeep Kategorie: Pro-Bot128 (von MatthiasK - 31.12.2016 10:34)
Als Antwort auf Dauerpeep von MarcusO - 24.12.2016 11:12
Ich nutze:
C-Control Pro Mega128
Hallo MarcusO,

ich habe das gleiche Problem, es ist mir auch schon beim Beep Systemtest aufgefallen.
Lass mich wissen falls du eine Lösung hast.


> Hallo ich habe einen ProBot geschenkt bekommen und natürlich acuh komplett zusammengebaut.
> Auch im Bereich Programmierung bin ich sicher kein Noob, aber dennoch habe ich verschiedene Fragen/Probleme mit dem ProBot.
>
> Hier die erste Frage!
>
> Code:
> Sub main()
>    PRO_BOT128_INIT()   'PRO-BOT128 System Init
>    AbsDelay(1000)      'Wait 1Sec.
>    Do
>      BLL_ON()            'Back LED left "ON"
>      BEEP(50,500)       'Beep
>      BLR_ON()            'Back LED right "ON"
>      BEEP(650,400)       'Beep
>      BEEP(150,250)
>      BLL_OFF()            'Back LED left "ON"
>      BEEP(1050,400)
>      BLR_OFF()            'Back LED right "ON"
>    Loop While 1
> End Sub
>
> Dieser Code funktioniert, und spielt ein paar Töne und LED-Lichter im Kreis.
>
> Wenn ich keine Do..Loop-Schleife verwende, wird das ganze natürlich nur einmal gespielt,
> aber am Ende erhalte ich einen Dauerpeep, auch wenn ich danach noch weitere Befehle
> laufen lasse. Insbesondere hilft es nicht Beep(0,0) oder Timer_T0Stop() aufzurufen,
> um das piepen zu beenden.
>
> Wie kann ich dafür Sorgen das der Piep aufhört (außer Reset!)?
>
> Danke für eure Tipps!
>
> MarcusO


    Antwort schreiben


Antworten:

Re: Dauerpeep (von UlliS - 4.01.2017 2:20)