Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Spannungsversorgung von Display und Sensoren Kategorie: Sonstige Hardware (von Honkomat - 1.02.2011 21:31)
Als Antwort auf Re: Spannungsversorgung von Display und Sensoren von Joerg - 1.02.2011 12:17
Ich nutze:
C-Control Pro Mega32
> > Hallo allerseits,
> >
> > ich habe vor kurzem angefangen, mit einer PRO-Mini-Station zu experimentieren und bin daf├╝r schon
> > ziemlich weit: Mini-Station mit drei DS18S20+ Temperatursensoren, einem 4x16 LCD im 4-Bit Modus
> > und drei Taster f├╝r eine Men├╝-Steuerung. Alles l├Ąuft super und ich habe inzwischen ein ziemlich
> > komplexes Basic-Programm reibungslos zum Laufen bekommen.
> >
> > Nun das Problem:
> > Alle Komponenten sind an den +5V Ausgang und GND der Mini-Station angeschlossen. Das schein zuviel.
> > In der Sekunde, in der die drei Sensoren die Temperatur errechnen, ziehen sie soviel Strom, dass der
> > Kontrast des Displays schw├Ącher wird. Wenn man nun auch noch einen Taster dr├╝ckt, kommt es des
> > ├Âfteren vor, dass im Display nur noch Zeichensalat angezeigt wird.
> > Das Problem mit dem Zeichensalat habe ich durch 100 Ohm Widerst├Ąnde in Reihe zu den Tastern beseitigt.
> > Das Kontrastproblem bleibt, sieht aber grunds├Ątzlich nur doof aus, funktionieren tut trotzdem alles.
> > Allerdings scheint mir diese L├Âsung nicht gerade elegant zu sein (zumal ich keine Ahnung von der
> > eigentlichen Elektronik habe und das mit den 100 Ohm Widerst├Ąnden eher geraten war).
> > Je weniger Sensoren ich anschlie├če, desto geringer das Problem. Lesen im extra gekauften C-Control
> > Praxisbuch f├╝r Einsteiger und tagelanges googeln haben mich nicht weitergebracht.
> >
> > So eine Zusammensetzung muss es doch tausendfach und ├Âfter schon funktionierend geben. Nur finde ich
> > einfach keinen Schaltplan oder andere Hinweise. Zumal ich zu allem ├ťbel auch noch Strom f├╝r die
> > Display-Beleuchtung brauche.
> > Kann mir da jemand auf die Spr├╝nge helfen?
> >
> > Vielen Dank schonmal und viele Gr├╝├če.
>
> Hallo,
>
> die DS18S20 ziehen im Betrieb doch nur 1mA. Sollten die 3mA denn Probleme machen?
>
> Gr├╝├če Joerg

Hi, ich kann's mir auch nicht erkl├Ąren, eigentlich nicht. Wenn sie parasit├Ąr laufen, ist das Pro-
blem weg. Ich habe auf die Antwort von Francesco nochmal weitere Informationen geschrieben.
Vielleicht hast du ja Lust, da nochmal reinzuschauen. Evtl. hast Du dann ja noch einen Tip.

Viele Gr├╝├če


    Antwort schreiben


Antworten:

Re: Spannungsversorgung von Display und Sensoren (von Ernst H. - 1.02.2011 22:25)