Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Mega32 + Projectboard: am Ende ratlos... Kategorie: Sonstige Hardware (von Peter F√ľrst - 18.07.2015 15:17)
Ich nutze:
C-Control Pro Mega32
Hallo zusammen!

Ich habe einen Mega32 im Projectboard, wobei im Augenblick Signale an
Interrupt 1 (PortD.3), Interrupt 2 (PortB.2) und PortC.2 vorgesehen sind.
An PortD.3 soll ein externes Signal, an PortB.2 und PortC.2. soll, extern
geschaltet, VCC anliegen.
Die Interrupts 1 und 2 sind als flankengetriggert aktiviert, PortC wird
gepollt (Timer 0 liefert eine 1msec-Uhr).
Alle diese Ports sind (explizit) als Eingang mit deaktiviertem internem
PullUp-Widerstand konfiguriert und haben eine Diode gegen Ausgang ("Only
the paranoid survive" ;-) vorgeschaltet.
Die Versorgungsspannung wird an ADC.0 (PortA.0) (auf Anfrage) gemessen,
wobei die Werte mit einem Spannungs-Me√üger√§t √ľbereinstimmen.
Das Projectboard ist √ľber die serielle Schnittstelle mit einem anderen
Rechner zur Auswertung verbunden (gesammelte Meßwerte werden auf Anfrage
√ľbertragen), und hat ein Netzteil oder eine Batterie als Spannungsver-
sorgung.

Nun sind einige Auffälligkeiten zu beobachten:

1) Bei serieller Verbindung zu einem PDA:
Wenn der PDA an seinem Netzteil betrieben wird, wird Interrupt 2 mit
einer Periode von ~20ms (ein sehr bekannter Wert ;-) erzeugt...
(NB: an den Ports sind noch keine Signalquellen angeschlossen!).
Interrupt 1 dagegen wird nicht beeinflußt.
Das Phänomen tritt nicht auf, wenn der PDA an Batterie betrieben wird
oder statt des PDA ein "normaler" PC angeschlossen ist. (Das Project-
board wurde hier in allen Fällen mit Netzteil betrieben)

2) Ein Problem, das sich allerdings, sobald bemerkt, mit entsprechenden
Vorwiderständen lösen läßt: Bei AUSgeschaltetem Projectboard ziehen die
Ports bei anliegendem Signal unangenehm hohe Ströme (bis 40mA/5V).
Besonders störend beim unabhängig aktiven externen Signal an PortD.3.

3) Dann gibt's schließlich noch einen (partiellen) "Showstopper", der
mich ratlos macht :-(
Interrupt 1 wird, allem bisherigen Versuchen nach, vom externen Signal
völlig korrekt getriggert, während PortB.2 und PortC.2 sich sehr seltsam
verhalten:
Bei Ber√ľhrung dieser Ports (mit den Fingern), z.T. auch beim An-/Ab-    
stecken der Eingänge, werden Interrupts 2 erzeugt, bzw. liefert das
Polling Signale. Der vorgesehene VCC-Impuls an diesen Ports bewirkt
dagegen gar nichts.
(Die Ber√ľhrungsempfindlichkeit l√§√üt sich mit den internen PullUp-Wider-
ständen verhindern, was aber verständlicherweise nicht weiter hilft :-)

Hat jemand eine Idee?



    Antwort schreiben


Antworten:

Re: Mega32 + Projectboard: am Ende ratlos... (von Torsten - 19.07.2015 10:29)
    Re: Mega32 + Projectboard: am Ende ratlos... (von Peter F. - 24.07.2015 11:00)