Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Webserver / 1Wire-Bus Kategorie: Programmierung Basic (von Daneie - 23.11.2015 14:20)
Als Antwort auf Re: Webserver / 1Wire-Bus von UlliS - 23.11.2015 10:19

> > > > > > Hallo zusammen,
> > > > > > ich hatte am 16.05.2015 http://ccpro.cc2net.eu/forum/lesenBB.php?thread=9384
> > > > > > berichtet, dass der Webserver st├Ąndig abst├╝rtzt. Hier bin ich weiter gekommen,
> > > > > > in der Form, dass der Webserver an sich (z. B. Webserver und I2C-Bus) stabil l├Ąuft.
> > > > > > Sobald ich den 1 Wire-Bus mitlaufen lasse, st├╝rtzt der Webserver ab. Lasse ich den
> > > > > > 1 Wire-Bus allein laufen, l├Ąuft dieser auch stabil (├╝ber Tage hinweg).
> > > > > > Auch hatte ich versucht, den 1 Wire-Bus in einer eigenen Task laufen zu lassen,
> > > > > > ohne Erfolg (Websever st├╝rtzt ebenfalls ab).
> > > > > > Hat jemand eine Idee was das sein kann?
> > > > > > Peter S.?
> > > > >
> > > > > Hallo,
> > > > > k├Ânntest du ein paar Programmzeilen posten.
> > > > > Gru├č Daneie
> > > >
> > > >
> > > > TCP/IP Stack erh├Âht?
> > > >
> > > TCP/IP Stack habe ich auch schon vergr├Â├čert, obwohl das mit dem 1 Wire-Bus nichts zu tun hat.
> > > Rest kommt noch.
> > > Wolle
> >
> > Hallo,
> > bei mir ist es offensichtlich so, dass der Server abst├╝rzt wenn bei einer 1Wire-Abfrage (20 Sensoren)
> > auf den Server zugegriffen wird.
> > Kann ich irgendwie feststellen ob auf den Server zugegriffen wird bevor 1Wire startet?
> >
> > Mit WEB_StopServer und WEB_StartServer geht nichts, da bleibt alles stehen.
> >
> > Ich hab auch schon mit WEB_StartServer alle 5 Min versucht.
> >
> > Eine andere M├Âglichkeit w├Ąre noch ein Raspberry als Server.
> > Hier m├╝sste ich aber auch ├╝ber den Router gehen um meine Messwerte darstellen zu k├Ânnen.
> > Geht das evt mit den anderen Ethernet-Befehlen? Wenn ja mit welchen und wie.
> >
> > Danke Daneie
> >
> >
> >
>
> Den TCP/IP Speicher hast du angepasst? (ca. 20kb)
>
>  
Ja nat├╝rlich!

Wie w├Ąre es mit einen Update.
So wie ich das sehe, liegt das Problem bei euch Entwicklern.
Oder ihr streicht das "Ethernet" aus der Produktbeschreibung.
Wo ich schon mal dabei bin. Was ist "C‑Graph‑Pro"?

Gr├╝├če Daneie


    Antwort schreiben


Antworten:

Re: Webserver / 1Wire-Bus (von UlliS - 3.12.2015 9:48)
    Re: Webserver / 1Wire-Bus (von Daneie - 4.12.2015 9:29)
        Re: Webserver / 1Wire-Bus (von Daneie - 4.12.2015 9:31)
            Re: Webserver / 1Wire-Bus (von UlliS - 4.12.2015 10:28)
                Re: Webserver / 1Wire-Bus (von Daneie - 2.02.2016 15:47)
                    Re: Webserver / 1Wire-Bus (von UlliS - 15.02.2016 10:36)
                       Re: Webserver / 1Wire-Bus (von Danei - 20.04.2016 21:14)
                          Re: Webserver / 1Wire-Bus (von Daneie - 27.04.2016 8:20)