Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Nach Timerstart keine Kommunikation mehr Kategorie: CC-Pro Unit & Appl.Board (von PeterS - 5.07.2008 18:42)
Als Antwort auf Re: Nach Timerstart keine Kommunikation mehr von UlliS - 5.07.2008 13:27

Hallo Steffen,

damit der geneigte Programmierer sich nicht selbst die SPI Kommunikation kaputt macht, habe ich ihn den
Interpreter damals ein 2 Sek. delay eingebaut. Das ganze läuft normalerweise so ab:

1. Unit wird eingeschaltet, aber USB braucht noch ein bischen, da der PC langsamer ist
2. Die Unit startet im Autostart die Applikation, USB ist immer noch nicht soweit
3. Der Interpreter wartet 2 Sek., in der Zeit ist USB fertig und der Mega8 auf dem Appl,board macht reset
4. Nach Reset ist C-Control Pro im Kommandomodus

Aus irgendeinem Grund reichen die 2 Sek. Verzögerung bei Dir nicht. Du solltest aber bei eingeschaltetem
Appl Board einen der beiden Resettaster betätigen können, und dann sollte der Interpreter gar nicht bei Dir
starten, sondern das System kommandobereit sein.

Alternativ, kauf Dir für €15 einen USB-seriell Wandler. Den kann man immer gebrauchen.

Gruss Peter

> > Hallo,
> >
> > Ich habe mich mal daran versucht die Timer zu testen. Da ich 6 PWM Kanäle benötige
> >  erschienen mir die Timer 1 und 3
> > sehr hilfreich. Das funktioniert auch ich erhalte mein PWM.
> > Doch leider ist jetzt keine Verbindung mehr per USB möglich.
> > Das Appl. Board wird erkannt und dann schreibt er  immer das gleiche Zeichen in das IDE Kommunikationsfenster.
> > Was wahrscheinlich daran liegt das die PWM jetzt dieses ASCII Bitmuster erzeugt.
> >
> > Wie kann ich das Modul wieder in den Grundzustand bringen und dafĂĽr sorgen das er nicht mehr autostartet?
> > Wenn ich Reset beim Einschalten drĂĽcke geht er ja in den Seriellen Programmiermodus.
> > Ich benötige aber den USB Programmiermodus ich habe keine erielle Schnittstell mehr.
> > Irgendwelche kreativen Ideen?
> >
> >
> >  
>
> Hi,
>
> schau dir mal die Pinzuordnung an...
> Und ganz genau OC3C :-)
>
> Dann dĂĽrfte alles klar sein.
>
> Schönes Wochenende
>
> GruĂź Ulli
>


    Antwort schreiben


Antworten:

Re: Nach Timerstart keine Kommunikation mehr (von Steffen - 7.07.2008 18:11)
    Re: Nach Timerstart keine Kommunikation mehr (von PeterS - 7.07.2008 23:12)