Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Problem mit der 2. Seriellen Schnittstelle Kategorie: Programmierung C (von wellental - 27.03.2011 15:06)


Servus!

Ich benutze den C-Control Pro Mega128 in Verbindung mit dem C-Control Pro 128 Projectboard,
das es bei Conrad hier zu kaufen gibt: http://tinyurl.com/63eepyt

In meiner Anwendung soll das Board ├╝ber RS232 mit einem PDA kommunizieren.
Das ist alles auch kein grosses Problem, nur funktioniert bei mir leider die 2. Serielle Schnittstelle
auf dem Board offensichtlich nicht so, wie sie soll. Diese ist ja ├╝ber die Pins D2 und D3 auf
dem Board verf├╝gbar, jedoch kommt da bei mir leider nur Schrott am PDA an.

An der Software auf dem PDA liegt's nicht, da ich am Rechner das gleiche Symptom habe und
ausserdem das ganze einwandfrei funktioniert, sobald ich die 1. Serielle Schnittstelle verwende,
die auf dem Board ├╝ber den 9 poligen Stecker nach aussen gef├╝hrt ist. Diese auf Dauer zu verwenden,
ist f├╝r mich keine Option, da diese auch zum Programmieren und vor allem zum Debuggen verwendet wird.

Die Signalmasse f├╝r den RS232-Anschluss zum Rechner hab ich mir ├╝brigens vom UNIT-BUS geklaut.
Das sollte aber wohl nicht das Problem sein, oder?

Danke schonmal,

Max


    Antwort schreiben


Antworten:

Re: Problem mit der 2. Seriellen Schnittstelle (von Franz-Peter - 27.03.2011 15:32)
    Re: Problem mit der 2. Seriellen Schnittstelle (von wellental - 27.03.2011 21:02)
        Re: Problem mit der 2. Seriellen Schnittstelle (von Franz-Peter - 27.03.2011 22:14)
            Re: Problem mit der 2. Seriellen Schnittstelle (von wellental - 27.03.2011 22:20)
Re: Problem mit der 2. Seriellen Schnittstelle (von wellental - 27.03.2011 15:08)