Zur Übersicht - INFO - Neueste 50 Beiträge - Neuer Beitrag - Suchen - Zum C-Control-I-Forum - Zum C-Control-II-Forum

Re: Konflikt auf Com1? Kategorie: Programmierung C (von MartinS - 24.06.2008 12:59)
Als Antwort auf Re: Konflikt auf Com1? von Hannes - 24.06.2008 11:12
Ich nutze:
C-Control Pro Mega128, eigenes Board
>
> Ist die COM1 am PC auf 115200 Bits/Sek. eingestellt? (Systemsteuerung)
> Wenn nicht, kommt was raus, was nicht rauskommen soll.
>
> Gruss

Hallo Hannes

Habe mittlerweile den Fehler gefunden, die Ausgabe funktioniert soweit mal.
Sie funktioniert allerdings nur, wenn ich die M128 mit der IDE starte.
Starte ich mit dem Start/stop-Schalter auf meinem eigenen Board ( Programmierterminal),
bringe ich keine Kommunikation zustande.
Muss noch herausfinden, warum das so ist.

Danke

Martin


>
>
>
>
> > > Hallo Martin,
> > >
> > > >Die Daten, die da aber zu sehen waren, entsprachen nicht im geringsten dem, was ├╝ber die serielle
> > > > Schnittstelle gesendet werden sollte.
> > >
> > > Das kann eigentlich nicht sein, da die IDE auch nur die Daten ausgibt, die ├╝ber die serielle kommen.
> > > Hast Du denn auch 38400, 8 Bit, no parity im Terminalprogramm ausgew├Ąhlt?
> >
> > Hallo Peter
> >
> > nein, ich hab die serielle Schnittstelle auf der M128 mit 115200, 8Bit, no parity, 1 Stopbit initialisiert
> > und dies auch im Terminalprogramm so eingegeben.
> >
> > >
> > > Nur wenn Du das Programm im Debugmodus startest, kommt es zur Kollision, da der Debugmodus versucht
> > > ├╝ber die serielle zu kommunizieren.
> >
> > Wenn den Prozessor ├╝ber die IDE starte, bin ich also im Debug-Mode?
> >
> >
> > >
> > > Gruss Peter
> > >
> > > > Hallo Zusammen
> > > >
> > > > tja, da hab ich doch schon wieder ein Problem mit der seriellen Schnittstelle...
> > > > Die Daten├╝bertragung mit Com1 funktioniert zwar, aber trotzdem stimmt da was nicht!
> > > > Starte ich den Prozessor mit der IDE (Button mit dem Blitz-symbol) werden die seriellen Daten
> > > > korrekt im Anzeige-Fenster ausgegeben.
> > > > Nun hab ich aber nach dem Start die IDE geschlossen und ein Terminal-Programm gestartet.
> > > > Die Daten, die da aber zu sehen waren, entsprachen nicht im geringsten dem, was ├╝ber die serielle
> > > > Schnittstelle gesendet werden sollte.
> > > > Frage:
> > > > Wie verwendet man die Com1 am besten?
> > > > Gibt es einen Konflikt zwischen der Kommunikation mit der IDE und einer Terminalkommunikation?
> > > > Muss ich, wenn ich eine serielle Schnittstelle zur Ausgabe von Daten verwenden m├Âchte, die Com2
> > > > verwenden?
> > > > Wenn ich auf die Com1 angewiesen bin, welchen Pegel muss der Start-Pin (X1-12, Port E4)
> > > > beim Booten des Prozessors haben? (Eigenes Board!)
> > > >
> > > > Besten Dank f├╝r eure ausf├╝hrlichen Antworten
> > > >
> > > > Gruss
> > > > MartinS


    Antwort schreiben


Antworten:

Re: Konflikt auf Com1? (von UlliS - 25.06.2008 9:13)
    Re: Konflikt auf Com1? (von MartinS - 26.06.2008 11:39)
        Re: Konflikt auf Com1? (von UlliS - 26.06.2008 14:44)
            Re: Konflikt auf Com1? (von MartinS - 27.06.2008 16:28)
    Re: Konflikt auf Com1? (von MartinS - 25.06.2008 23:54)